Wednesday, January 27, 2010

Fixing Packman Repository error for openSUSE 11.2

For a couple of days now, when ever I do a zypper operation (and the resulting repo refresh) I get the following error message:

Repository 'Packman Repository' is invalid.
Can't provide /repodata/repomd.xml : Can't hardlink/copy /var/adm/mount/AP_0x00000001/repodata/repomd.xml to /var/cache/zypp/raw/
Please check if the URIs defined for this repository are pointing to a valid repository.
Warning: Disabling repository 'Packman Repository' because of the above error.

Since I added the Packman repo via Yast (Yast -> Software -> Software Repositories -> Add -> Community Repositories) I was scratching my head trying to find out why. Then it hit me that Packman does not use a redirector URL like

To resolve it I added another location for Packman (with autorefresh enabled):

zypper ar -f Packman

Then refresh the repo

zypper refresh Packman

For a list of additional repos you can add to openSUSE 11.2, do refer to

Sunday, January 10, 2010 3.2.0 Build 9319 Available for openSUSE

OO.o 3.2 is now available via the Unstable repo for openSUSE. 

Just add the below repo using zypper:

zypper ar openSUSE\ 11.2\ OpenOffice\ Unstable

Change 11.2 to 11.1 or 11.0 if you are not running 11.2.

One of the coolest things of running openSUSE is the availability of the latest OO.o from the devels themselves, since Novell sponsors the excellent Go-oo variant of Go-oo has better support for OOXML and VBA macros,  GStreamer integration and 3D transition for Impress. Go-oo is the default bundled with other distros such as Ubuntu and Mandriva. Go-oo also has a version for MS Windows.